<!DOCTYPE html>
<html lang="en-GB">
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://cyprusscene.com/xmlrpc.php" />

	<!--[if lt IE 9]>
	<script src="https://cyprusscene.com/wp-content/themes/broadsheet/js/html5.js" type="text/javascript"></script>
	<![endif]-->

	<title>Raindrops Keep Falling On My Head | CyprusScene.com</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Arimo:r:latin,latin-ext","Arimo:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://cyprusscene.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active body{font-family:"Arimo",sans-serif}.wf-active body, .wf-active button, .wf-active input, .wf-active select, .wf-active textarea{font-family:"Arimo",sans-serif}.wf-active h1, .wf-active h2, .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6{font-family:"Arimo",sans-serif;font-weight:400;font-style:normal}.wf-active h1{font-style:normal;font-weight:400}.wf-active h2{font-style:normal;font-weight:400}.wf-active h3{font-style:normal;font-weight:400}.wf-active h4{font-style:normal;font-weight:400}.wf-active h5{font-style:normal;font-weight:400}.wf-active h6{font-style:normal;font-weight:400}</style>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="The" />
<meta name="msvalidate.01" content="The" />
<meta name="p:domain_verify" content="The" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CyprusScene.com &raquo; Feed" href="https://cyprusscene.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CyprusScene.com &raquo; Comments Feed" href="https://cyprusscene.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CyprusScene.com &raquo; Raindrops Keep Falling On My Head Comments Feed" href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cyprusscene.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sdm-styles-css'  href='https://cyprusscene.com/wp-content/plugins/simple-download-monitor/css/sdm_wp_styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpcom-text-widget-styles-css'  href='https://cyprusscene.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/text-media-widget-styles/css/widget-text.css?ver=20170607' type='text/css' media='all' />
<link rel='stylesheet' id='events-manager-css'  href='https://cyprusscene.com/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.97' type='text/css' media='all' />
<link rel='stylesheet' id='sow-image-grid-default-c51e448a0a62-css'  href='https://cyprusscene.com/wp-content/uploads/siteorigin-widgets/sow-image-grid-default-c51e448a0a62.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='broadsheet-style-css'  href='https://cyprusscene.com/wp-content/themes/broadsheet/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/8.0/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='broadsheet-style-neuton-css'  href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_facebook_likebox-css'  href='https://c0.wp.com/p/jetpack/8.0/modules/widgets/facebook-likebox/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-css'  href='https://cyprusscene.com/wp-content/plugins/newsletter/style.css?ver=6.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.0/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.0/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/mouse.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/sortable.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/datepicker.min.js'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/menu.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/dist/vendor/wp-polyfill.min.js'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://cyprusscene.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://cyprusscene.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://cyprusscene.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://cyprusscene.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/dist/dom-ready.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/dist/a11y.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/autocomplete.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/resizable.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/draggable.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/button.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/dialog.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EM = {"ajaxurl":"https:\/\/cyprusscene.com\/wp-admin\/admin-ajax.php","locationajaxurl":"https:\/\/cyprusscene.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"1","locale":"en","dateFormat":"dd\/mm\/yy","ui_css":"https:\/\/cyprusscene.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.min.css","show24hours":"0","is_ssl":"1","google_maps_api":"AIzaSyAb_IS03MlorxA4gFNHLLpAnHQ2GTg0duE","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://cyprusscene.com/wp-content/plugins/events-manager/includes/js/events-manager.js?ver=5.97'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sdm_ajax_script = {"ajaxurl":"https:\/\/cyprusscene.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cyprusscene.com/wp-content/plugins/simple-download-monitor/js/sdm_wp_scripts.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var js_i18n = {"next":"next","prev":"previous","menu":"Menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cyprusscene.com/wp-content/themes/broadsheet/js/main.js?ver=1.0'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/jquery.jetpack-resize.min.js'></script>
<link rel='https://api.w.org/' href='https://cyprusscene.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cyprusscene.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cyprusscene.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Local Football Fixtures for weekend 21/22 December' href='https://cyprusscene.com/2019/12/19/local-football-fixtures-for-weekend-21-22-december/' />
<link rel='next' title='Speaker of TRNC Assembly Uluçay attended General Council meeting' href='https://cyprusscene.com/2019/12/19/speaker-of-trnc-assembly-ulucay-attended-general-council-meeting/' />

<link rel='shortlink' href='https://wp.me/p2D1U6-2Kay' />
<link rel="alternate" type="application/json+oembed" href="https://cyprusscene.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcyprusscene.com%2F2019%2F12%2F19%2Fraindrops-keep-falling-on-my-head%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cyprusscene.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcyprusscene.com%2F2019%2F12%2F19%2Fraindrops-keep-falling-on-my-head%2F&#038;format=xml" />
<!-- SEO meta tags powered by SmartCrawl -->
<link rel="canonical" href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" />
<meta name="description" content="By Ahmet Abdulaziz.... More than once I have written about rain and “Raindrops keep falling on my head”  sung by B.J. Thomas.  This is one of my favourite songs. But today I am writing about the real raindrops which keep on falling on my head. Walking in the rain is what I like the most. Unfortu ..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" />
<meta property="og:title" content="Raindrops Keep Falling On My Head | CyprusScene.com" />
<meta property="og:description" content="By Ahmet Abdulaziz.... More than once I have written about rain and “Raindrops keep falling on my head”  sung by B.J. Thomas.  This is one of my favourite songs. But today I am writing about the real raindrops which keep on falling on my head. Walking in the rain is what I like the most. Unfortu ..." />
<meta property="og:image" content="https://cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg" />
<meta property="og:image:width" content="350" />
<meta property="og:image:height" content="250" />
<meta property="article:published_time" content="2019-12-19T14:05:03" />
<meta property="article:author" content="ahmet abdulaziz" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Raindrops Keep Falling On My Head | CyprusScene.com" />
<meta name="twitter:description" content="By Ahmet Abdulaziz.... More than once I have written about rain and “Raindrops keep falling on my head”  sung by B.J. Thomas.  This is one of my favourite songs. But today I am writing about the real raindrops which keep on falling on my head. Walking in the rain is what I like the most. Unfortu ..." />
<meta name="twitter:image" content="https://cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg" />
<script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"WebSite","about":"The friend of Northern Cyprus shares its Daily News of Life and Times around the world","dateModified":"2019-12-19 16:50:48.000000","description":"The friend of Northern Cyprus shares its Daily News of Life and Times around the world","encoding":"UTF-8","headline":"CyprusScene.com","inLanguage":"en-GB","name":"CyprusScene.com","publisher":{"@type":"Organization","name":"CyprusScene.com"},"url":"https:\/\/cyprusscene.com"},{"@context":"http:\/\/schema.org","@type":"Article","author":{"@type":"Person","name":"ahmet abdulaziz","url":"https:\/\/cyprusscene.com\/author\/ahmet\/"},"commentCount":"0","dateModified":"2019-12-19T14:05:03","datePublished":"2019-12-19T14:05:03","description":"By Ahmet Abdulaziz.... More than once I have written about rain and \u201cRaindrops keep falling on my head\u201d\u00a0 sung by B.J. Thomas.\u00a0 This is one of my favourite songs. But today I am writing about the real raindrops which keep on falling on my head. Walking in the rain is what I like the most. Unfortu ...","headline":"Raindrops Keep Falling On My Head | CyprusScene.com","image":{"@context":"http:\/\/schema.org","@type":"ImageObject","height":250,"url":"https:\/\/i0.wp.com\/cyprusscene.com\/wp-content\/uploads\/2018\/12\/Raining-image-2.jpg?fit=350%2C250&ssl=1","width":350},"mainEntityOfPage":"https:\/\/cyprusscene.com\/2019\/12\/19\/raindrops-keep-falling-on-my-head\/","name":"Raindrops Keep Falling On My Head","publisher":{"@type":"Organization","name":"CyprusScene.com","logo":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/?s=96&d=wavatar&r=g","height":60,"width":60}},"thumbnailUrl":"https:\/\/i0.wp.com\/cyprusscene.com\/wp-content\/uploads\/2018\/12\/Raining-image-2.jpg?fit=350%2C250&ssl=1","url":"https:\/\/cyprusscene.com\/2019\/12\/19\/raindrops-keep-falling-on-my-head\/"}]</script>
<!-- /SEO -->

<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="description" content="By Ahmet Abdulaziz.... More than once I have written about rain and “Raindrops keep falling on my head”  sung by B.J. Thomas.  This is one of my favourite songs. But today I am writing about the real raindrops which keep on falling on my head. Walking in the rain is what I like the most.&hellip;" />
<style>
	.masthead .branding h1.logo a,
	.masthead .branding h1.logo a:hover,
	.masthead .branding h2.description {
		color:#000;
	}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #44749d; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Raindrops Keep Falling On My Head" />
<meta property="og:url" content="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" />
<meta property="og:description" content="By Ahmet Abdulaziz&#8230;. More than once I have written about rain and “Raindrops keep falling on my head”  sung by B.J. Thomas.  This is one of my favourite songs." />
<meta property="article:published_time" content="2019-12-19T12:05:03+00:00" />
<meta property="article:modified_time" content="2019-12-19T12:05:03+00:00" />
<meta property="og:site_name" content="CyprusScene.com" />
<meta property="og:image" content="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?fit=350%2C250&amp;ssl=1" />
<meta property="og:image:width" content="350" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:creator" content="@Kyreniacomment" />
<meta name="twitter:site" content="@Kyreniacomment" />
<meta name="twitter:text:title" content="Raindrops Keep Falling On My Head" />
<meta name="twitter:image" content="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?fit=350%2C250&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<style type="text/css" id="custom-colors-css">.sidebar-category-summaries .item h4 span{opacity:.9}.infinite-scroll #infinite-handle span,input[type=submit],ol.commentlist li.comment .reply a,ol.commentlist li.trackback .reply a,ol.commentlist li.pingback .reply a{border:0;background-image:none}.infinite-scroll #infinite-handle span:hover,input[type=submit]:hover,ol.commentlist li.comment .reply a:hover,ol.commentlist li.trackback .reply a:hover,ol.commentlist li.pingback .reply a:hover{border:0;background-image:none}input[type=search]:focus,input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,input.settings-input:focus{outline-color:#fff !important;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;border:1px solid #e6e6e6}.primary-content nav a{background-color:#ccc}.menu-primary .menu li ul li{border-bottom:1px solid rgba(0,0,0,.05)}body{background-color:#000}.menu-primary .menu li ul,.menu-primary .menu li.current-menu-item a{background-color:#e2e2e2}.menu-primary .menu li ul,.menu-primary .menu li.current-menu-item a{color:#000}.masthead .branding h1.logo a,.masthead .branding h1.logo a:hover,.masthead .branding h2.description{color:#1a1a1a}.widget-title{color:#1a1a1a}.menu{border-bottom-color:#1a1a1a}.showcase{background:#f8fbfd}.showcase{border-bottom-color:#7fb6db}.sidebar-category-summaries .item h4 span{background-color:#7fb6db}.sidebar-category-summaries .item h4 span:hover{background-color:#2a6b97}.primary-content .primary-wrapper .item .image-meta{background-color:#7fb6db}.primary-content .primary-wrapper .item .image-meta:hover{background-color:#2a6b97}.text-by,.text-on,.commentcount,.primary-content .primary-wrapper .item .postmetadata{color:#779aab}.primary-content nav a.selected{background-color:#779aab}.main article a.post-lead-category{background-color:#f8fbfd}.main article a.post-lead-category:hover{background-color:#7fb6db}.primary-content .primary-wrapper .item .image-meta{color:#f8fbfd}.menu-primary .menu li ul:before{border-bottom-color:#f8fbfd}.menu-primary .menu li ul a{color:#f8fbfd}.infinite-scroll #infinite-handle span,input[type=submit],.main .archive-pagination span.current,ol.commentlist li.comment .reply a,ol.commentlist li.trackback .reply a,ol.commentlist li.pingback .reply a{background-color:#779aab}.infinite-scroll #infinite-handle span,.infinite-scroll #infinite-handle span:hover,input[type=submit],input[type=submit]:hover,ol.commentlist li.comment .reply a:hover,ol.commentlist li.trackback .reply a:hover,ol.commentlist li.pingback .reply a:hover{background-color:#779aab}a{color:#2473a7}.menu-primary .menu li a{color:#2473a7}.menu-primary .menu ul li a:before,{color:#2980b9}.menu-primary .menu li.page_item_has_children>a:after,.menu-primary .menu li.menu-item-has-children>a:after{border-top-color:#2980b9}.menu-primary .menu li.current-menu-item.page_item_has_children>a:after,.menu-primary .menu li.current-menu-item.menu-item-has-children>a:after{border-top-color:#2473a7}.showcase a,.showcase a:hover,.showcase a:visited{color:#2980b9}.posttitle,.posttitle a{color:#2980b9}.menu-primary .menu li ul li a,.menu-primary .menu li ul li a:hover{color:#6b6b6b}.showcase .postmetadata{color:#fff}.showcase{color:#fff}h3.widgettitle:before,form.searchform button.searchsubmit{color:#6d6d6d}.postmetadata{color:#6d6d6d}body{color:#6d6d6d}blockquote{border-left-color:#fff}pre{color:#fff}pre{background-color:#6d6d6d}input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,input.settings-input:focus{border-color:#fff}</style>
<link rel="icon" href="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2018/08/cropped-CyprusScene-logo-1.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2018/08/cropped-CyprusScene-logo-1.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2018/08/cropped-CyprusScene-logo-1.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2018/08/cropped-CyprusScene-logo-1.jpg?fit=270%2C270&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				/* Footer background color - ZD-1738788-SB*/
footer#footer .footer-wrap {
    background:#dbd8d6;
}

footer#footer .footer-wrap ul {
    margin-left: 10px;
    margin-right: 0px;
}

/* Main content background color - ZD-1738788-SB*/

.main #main-content {
        background:#dbd8d6;
        padding-left: 10px;
}

/* Menu background color - ZD-1738788-SB*/

.menu-primary .menu ul {
     background :#dbd8d6;
}
footer#footer .footer-widgets {
    background:#dbd8d6;
}
@media screen and (max-width: 782px) {
  /* Show left sidebar in mobile for Floral theme / #hc-9971660 lm */
  .main .sidebar-small {
    display: block;
  }
}
			</style>
		</head>

<body class="post-template-default single single-post postid-654134 single-format-standard custom-background wp-custom-logo singular themes-sidebar1-active themes-sidebar2-active themes-sidebar3-active themes-category-summaries-inactive themes-has-featured-posts themes-no-primary-content custom-colors">

<div class="container hfeed">

	<header class="masthead" role="banner">

		
		<div class="branding">


			<h1 class="logo">
				<a href="https://cyprusscene.com/" title="Home">
					CyprusScene.com				</a>
			</h1>

			<h2 class="description">
				The friend of Northern Cyprus shares its Daily News of Life and Times around the world			</h2>

			<div class="postmetadata">
<span class="header-date">Thursday, December 19th, 2019</span><span class="sep">|</span><div class="social_links menu-social-links"><a href="http://twitter.com/Kyreniacomment" class="social_link_twitter"><span>Twitter<span></a><a href="https://www.facebook.com/cyprusscene/" class="social_link_facebook"><span>Facebook<span></a><a href="https://plus.google.com/108259488521191588705" class="social_link_google_plus"><span>Google+<span></a><a href="http://kyreniacommentator.tumblr.com/" class="social_link_tumblr"><span>Tumblr<span></a><a href="http://www.linkedin.com/profile/view?id=AAoAAA0822gBMwFURhop2dO9v3lv81Wyg4GQNTw" class="social_link_linkedin"><span>LinkedIn<span></a></div>			</div>

		</div>

		<form method="get" class="searchform" action="https://cyprusscene.com/" role="search">
	<label>
		<span class="screen-reader">Search for...</span>
		<input type="search" value="" name="s" class="searchfield text" placeholder="Search..." />
	</label>
	<button class="searchsubmit">&#62464;</button>
</form>

	</header>

			<a href="https://cyprusscene.com/" title="CyprusScene.com" rel="home" class="header-image">
			<img src="https://cyprusscene.com/wp-content/uploads/2017/04/cropped-cyprusscene-8-header.jpg" width="1140" height="320" alt="" />
		</a>

	<nav class="menu-primary" role="navigation">
		<div class="menu">
			<h3 class="menu-toggle">Menu</h3>
<div class="menu-cyprusscene-menu-container"><ul id="nav" class="menu-wrap clearfix"><li id="menu-item-597255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-597255"><a href="https://cyprusscene.com/">Home</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23"><a href="https://cyprusscene.com/about/">Cyprusscene</a></li>
<li id="menu-item-16172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16172"><a href="https://cyprusscene.com/category/chefs-choice/">Chef&#8217;s Choice</a></li>
<li id="menu-item-674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-674"><a href="https://cyprusscene.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-11205" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11205"><a href="https://cyprusscene.com/category/brt/">BRT Radio and Television</a></li>
	<li id="menu-item-3287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3287"><a href="https://cyprusscene.com/category/events-calendar/">Events Calendar</a></li>
	<li id="menu-item-56523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56523"><a href="https://cyprusscene.com/category/quiz/">Quiz</a></li>
</ul>
</li>
<li id="menu-item-3471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3471"><a href="https://cyprusscene.com/games-to-play-on-cyprusscenecom/">Game Zone</a></li>
<li id="menu-item-36389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36389"><a href="https://cyprusscene.com/category/services/health/">Health</a></li>
<li id="menu-item-655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-655"><a href="https://cyprusscene.com/category/heritage/">Heritage &#8211; Places</a></li>
<li id="menu-item-383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383"><a href="https://cyprusscene.com/category/news/">News</a></li>
<li id="menu-item-378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-378"><a href="https://cyprusscene.com/category/information/">Information</a></li>
<li id="menu-item-3180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3180"><a href="https://cyprusscene.com/3071-2/">Local Contacts</a></li>
<li id="menu-item-742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-742"><a href="https://cyprusscene.com/services/">Services</a>
<ul class="sub-menu">
	<li id="menu-item-2939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2939"><a href="https://cyprusscene.com/category/services/animal-care/">Animal care</a></li>
	<li id="menu-item-735" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-735"><a href="https://cyprusscene.com/category/services/automobile/">Automobile</a></li>
	<li id="menu-item-17678" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17678"><a href="https://cyprusscene.com/category/services/auctions/">Auctions</a></li>
	<li id="menu-item-9683" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9683"><a href="https://cyprusscene.com/category/services/chimney-sweep/">Chimney Sweep</a></li>
	<li id="menu-item-10252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10252"><a href="https://cyprusscene.com/category/services/education/">Education</a></li>
	<li id="menu-item-92295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92295"><a href="https://cyprusscene.com/category/employment/">Employment</a></li>
	<li id="menu-item-1311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1311"><a href="https://cyprusscene.com/category/services/finance/">Finance</a></li>
	<li id="menu-item-31235" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31235"><a href="https://cyprusscene.com/category/services/food-and-drink/">Food and Drink</a>
	<ul class="sub-menu">
		<li id="menu-item-32482" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32482"><a href="https://cyprusscene.com/category/services/food-and-drink/wine-and-beer/">Wine and Beer</a></li>
	</ul>
</li>
	<li id="menu-item-18449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18449"><a href="https://cyprusscene.com/category/services/for-sale/">FOR SALE</a></li>
	<li id="menu-item-737" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-737"><a href="https://cyprusscene.com/category/services/health/">Health</a></li>
	<li id="menu-item-738" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-738"><a href="https://cyprusscene.com/category/services/household/">Household</a></li>
	<li id="menu-item-21538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21538"><a href="https://cyprusscene.com/category/services/market/">Market</a></li>
	<li id="menu-item-6049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6049"><a href="https://cyprusscene.com/category/services/property/">Property</a></li>
	<li id="menu-item-31491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31491"><a href="https://cyprusscene.com/category/services/religion/">Religion</a></li>
	<li id="menu-item-7081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7081"><a href="https://cyprusscene.com/category/services/restaurantsbars/">Restaurants/Bars</a></li>
	<li id="menu-item-1471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1471"><a href="https://cyprusscene.com/category/services/shops/">Shops</a>
	<ul class="sub-menu">
		<li id="menu-item-8654" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8654"><a href="https://cyprusscene.com/category/services/shops/book-shop/">Book Shop</a></li>
		<li id="menu-item-32474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32474"><a href="https://cyprusscene.com/category/services/shops/cycle-shop/">Cycle Shop</a></li>
		<li id="menu-item-8655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8655"><a href="https://cyprusscene.com/category/services/shops/hairdressers/">Hairdressers</a></li>
	</ul>
</li>
	<li id="menu-item-6354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6354"><a href="https://cyprusscene.com/category/services/tourism/">Tourism</a></li>
	<li id="menu-item-5174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5174"><a href="https://cyprusscene.com/category/services/weddings/">Weddings</a></li>
	<li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-377"><a href="https://cyprusscene.com/category/social-needs/charities-and-associations/">Charities and Associations</a>
	<ul class="sub-menu">
		<li id="menu-item-3811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3811"><a href="https://cyprusscene.com/category/social-needs/cesv-civil-emergency-service-voulunteers/">CESV &#8211; Civil Emergency Service Voulunteers</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-670" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-670"><a href="https://cyprusscene.com/category/services/sport/">Sport</a></li>
<li id="menu-item-588733" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-588733"><a href="https://cyprusscene.com/category/readers-mail/">Readers Mail</a></li>
<li id="menu-item-97093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97093"><a href="https://cyprusscene.com/services-a-to-z/">Services A to Z</a></li>
<li id="menu-item-380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-380"><a href="https://cyprusscene.com/category/trevors-corner/">Trevors Tips</a></li>
<li id="menu-item-610443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-610443"><a href="https://cyprusscene.com/e-newspaper/">E-Newspaper</a></li>
<li id="menu-item-635780" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-635780"><a href="https://cyprusscene.com/e-news-downloads/">E-News Downloads</a></li>
<li id="menu-item-634838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-634838"><a href="https://cyprusscene.com/newsletter-2/">Newsletter</a></li>
</ul></div>		</div>
	</nav>

	<div class="main">
<div class="col-sidebar sidebar-small" role="complementary">
<section id="media_image-60" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle">Take a look at our Enewspaper which you can read page by page by clicking the picture below</h3><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://cyprusscene.com/3d-flip-book/cyprusscene-com-enewspaper-issue-105/"><img width="300" height="214" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?fit=300%2C214&amp;ssl=1" class="image wp-image-653939 aligncenter attachment-medium size-medium jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="653939" data-permalink="https://cyprusscene.com/2019/12/13/cyprusscene-com-online-enewspaper-issue-105-has-arrived/cyprusscene-com-enewspaper-issue-105-pdf_page_01-image/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?fit=350%2C250&amp;ssl=1" data-orig-size="350,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CyprusScene.com Enewspaper Issue 105.pdf_page_01 image" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?fit=350%2C250&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?w=350&amp;ssl=1 350w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?resize=300%2C214&amp;ssl=1 300w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?resize=150%2C107&amp;ssl=1 150w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf_page_01-image.jpg?fit=300%2C214&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section><section id="media_image-71" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle">Click below to download the latest Enewspaper in PDF format</h3><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://cyprusscene.com/wp-content/uploads/2019/12/CyprusScene.com-Enewspaper-Issue-105.pdf"><img width="150" height="107" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?fit=150%2C107&amp;ssl=1" class="image wp-image-635785 aligncenter attachment-thumbnail size-thumbnail jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="635785" data-permalink="https://cyprusscene.com/download-image/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?fit=350%2C250&amp;ssl=1" data-orig-size="350,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Download image" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?fit=350%2C250&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?w=350&amp;ssl=1 350w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?resize=150%2C107&amp;ssl=1 150w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?resize=300%2C214&amp;ssl=1 300w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/02/Download-image.jpg?fit=150%2C107&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section><section id="newsletterwidget-2" class="widget widget_newsletterwidget"><div class="widget-wrap"><h3 class="widgettitle">CyprusScene.com Enewspaper Subscription</h3>Welcome and to sign up to receive a weekly newsletter about our weekly CyprusScene.com Enewspaper, please complete the subscription_form<div class="tnp tnp-widget"><form method="post" action="https://cyprusscene.com/?na=s" onsubmit="return newsletter_check(this)">

<input type="hidden" name="nlang" value="">
<input type="hidden" name="nr" value="widget">
<input type='hidden' name='nl[]' value='0'>
<div class="tnp-field tnp-field-firstname"><label>Name</label><input class="tnp-firstname" type="text" name="nn" ></div>
<div class="tnp-field tnp-field-email"><label>Email</label><input class="tnp-email" type="email" name="ne" required></div>
<div class="tnp-field tnp-field-privacy"><label><input type="checkbox" name="ny" required class="tnp-privacy">&nbsp;Subscribing I accept the privacy rules of this site</label></div>
<div class="tnp-field tnp-field-button"><input class="tnp-submit" type="submit" value="Subscribe" >
</div>
</form>
</div>
</div></section><section id="facebook-likebox-3" class="widget widget_facebook_likebox"><div class="widget-wrap"><h3 class="widgettitle"><a href="https://www.facebook.com/pages/cyprusscenecom/1440436979526868">Cyprusscene.com on Facebook</a></h3>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/pages/cyprusscenecom/1440436979526868" data-width="270"  data-height="600" data-hide-cover="false" data-show-facepile="true" data-tabs="timeline">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/pages/cyprusscenecom/1440436979526868"><a href="https://www.facebook.com/pages/cyprusscenecom/1440436979526868">Cyprusscene.com on Facebook</a></blockquote></div>
		</div>
		</div></section><section id="text-17" class="widget widget_text"><div class="widget-wrap"><h3 class="widgettitle">First time visitors to Cyprusscene.com</h3>			<div class="textwidget"><a href="http://info.flagcounter.com/qdlB"><img src="http://s04.flagcounter.com/count/qdlB/bg_FFF3CC/txt_000000/border_968F8F/columns_2/maxflags_43/viewers_Cyprusscene+readers/labels_1/pageviews_0/flags_0/" alt="Flag Counter" border="1" data-lazy-src="http://s04.flagcounter.com/count/qdlB/bg_FFF3CC/txt_000000/border_968F8F/columns_2/maxflags_43/viewers_Cyprusscene+readers/labels_1/pageviews_0/flags_0/?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="http://s04.flagcounter.com/count/qdlB/bg_FFF3CC/txt_000000/border_968F8F/columns_2/maxflags_43/viewers_Cyprusscene+readers/labels_1/pageviews_0/flags_0/" alt="Flag Counter" border="1"/></noscript></a></div>
		</div></section><section id="blog_subscription-5" class="widget widget_blog_subscription jetpack_subscription_widget"><div class="widget-wrap"><h3 class="widgettitle">Subscribe to cyprusscene.com</h3>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-5">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe and receive notifications of new posts by email.</p>
</div><p>Join 4,056 other subscribers.</p>
                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-5">
							Email Address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-5"
                               placeholder="Email Address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-5"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</div></section></div>
	<div class="main-content">
<article id="post-654134" class="post-654134 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-childhood-memories tag-rain-drops-keep-falling-on-my-head tag-raining">
<img width="350" height="250" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?resize=350%2C250&amp;ssl=1" class="post-header-image wp-post-image jetpack-lazy-image" alt="" data-attachment-id="632985" data-permalink="https://cyprusscene.com/2018/12/21/when-it-rains-what-are-the-effects/raining-image-2/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?fit=350%2C250&amp;ssl=1" data-orig-size="350,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Raining image 2" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?fit=350%2C250&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?w=350&amp;ssl=1 350w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?resize=150%2C107&amp;ssl=1 150w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?resize=300%2C214&amp;ssl=1 300w" data-lazy-sizes="(max-width: 350px) 100vw, 350px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/12/Raining-image-2.jpg?resize=350%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><a href="https://cyprusscene.com/category/reviews/" class="post-lead-category">Reviews</a>
<h1 class="title">Raindrops Keep Falling On My Head</h1>	<div class="postmetadata">
<span class="text-by">By</span> <span class="author vcard"><a class="url fn n" href="https://cyprusscene.com/author/ahmet/" title="View all posts by ahmet abdulaziz" rel="author">ahmet abdulaziz</a></span> <span class="text-on">on</span> <a href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" title="2:05 pm" rel="bookmark"><time class="entry-date" datetime="2019-12-19T14:05:03+02:00">December 19, 2019</time></a>		<span class="sep">&bull;</span> <span class="commentcount">( <a href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/#respond">Leave a comment</a> )</span>
	</div>
	<section class="entry">
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif"><strong>By Ahmet Abdulaziz&#8230;.</strong></span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">More than once I have written about rain and “Raindrops keep falling on my head”  sung by B.J. Thomas.  This is one of my favourite songs.<span id="more-654134"></span></span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">But today I am writing about the real raindrops which keep on falling on my head.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif"><img data-attachment-id="652079" data-permalink="https://cyprusscene.com/2019/11/19/walking-around-the-historic-walls-of-istanbul/ahmet-abdulaziz-window-page-3-1-2/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?fit=374%2C166&amp;ssl=1" data-orig-size="374,166" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ahmet-Abdulaziz-window-Page-3-1" data-image-description data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?fit=300%2C133&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?fit=374%2C166&amp;ssl=1" class="alignleft size-medium wp-image-652079 jetpack-lazy-image" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?resize=300%2C133&#038;ssl=1" alt width="300" height="133" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?resize=300%2C133&amp;ssl=1 300w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?resize=150%2C67&amp;ssl=1 150w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?w=374&amp;ssl=1 374w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?resize=300%2C133&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="652079" data-permalink="https://cyprusscene.com/2019/11/19/walking-around-the-historic-walls-of-istanbul/ahmet-abdulaziz-window-page-3-1-2/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?fit=374%2C166&amp;ssl=1" data-orig-size="374,166" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ahmet-Abdulaziz-window-Page-3-1" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?fit=300%2C133&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?fit=374%2C166&amp;ssl=1" class="alignleft size-medium wp-image-652079" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?resize=300%2C133&#038;ssl=1" alt="" width="300" height="133" srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?resize=300%2C133&amp;ssl=1 300w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?resize=150%2C67&amp;ssl=1 150w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/11/Ahmet-Abdulaziz-window-Page-3-1.jpg?w=374&amp;ssl=1 374w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript>Walking in the rain is what I like the most. Unfortunately, my wife, like my mother, always stops me from enjoying rain in real sense. According to my views, rain can be enjoyed only by getting wet. I love walking in the rain and getting wet.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">Last week, there was heavy rain in Lefkoşa (Nicosia), and I was working on a large painting in the studio. The painting was supposed to be delivered urgently. So I was struggling hard to bring it to the point where I would be able to finish it on the following Sunday.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">My studio is at a distance of about 2,5 kilometers from my house, and as usual that day too I had not brought my car since I walk from my house to the studio and back daily. So that was the case on that particular evening.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">As it started getting dark, my wife phoned me saying that she was coming to pick me, as it was constantly raining. I told her that I would be working late, and I would phone her when I wanted to return home, so she would be able to come and pick me up. At eight at night she once again phoned me, and this time in a sharp tone, she told me it was too late, and she was just<img data-attachment-id="613057" data-permalink="https://cyprusscene.com/2018/01/25/everyone-is-an-artist/ahmet-abdulaziz-2/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?fit=250%2C238&amp;ssl=1" data-orig-size="250,238" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ahmet Abdulaziz 2" data-image-description data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?fit=250%2C238&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?fit=250%2C238&amp;ssl=1" class="alignright size-full wp-image-613057 jetpack-lazy-image" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?resize=250%2C238&#038;ssl=1" alt width="250" height="238" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?w=250&amp;ssl=1 250w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?resize=150%2C143&amp;ssl=1 150w" data-lazy-sizes="(max-width: 250px) 100vw, 250px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?resize=250%2C238&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="613057" data-permalink="https://cyprusscene.com/2018/01/25/everyone-is-an-artist/ahmet-abdulaziz-2/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?fit=250%2C238&amp;ssl=1" data-orig-size="250,238" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ahmet Abdulaziz 2" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?fit=250%2C238&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?fit=250%2C238&amp;ssl=1" class="alignright size-full wp-image-613057" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?resize=250%2C238&#038;ssl=1" alt="" width="250" height="238" srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?w=250&amp;ssl=1 250w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/01/Ahmet-Abdulaziz-2.jpg?resize=150%2C143&amp;ssl=1 150w" sizes="(max-width: 250px) 100vw, 250px" data-recalc-dims="1" /></noscript> coming. Once again I told her not to come, and I would call her when I finished my work. “Do not walk, it is raining heavily, do not get wet and sick”, were her harsh and admonishing words.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">Looking out of the window, it was terribly dark and raining. I knew some roads would have been flooded, and it would not be sensible on my part to walk. But the obstinate person that I am, I never wanted to lose that chance of walking in the rain.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">So I left, at about 9,30pm. It was dark and raining. I put on my jacket with headgear, and went off.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">For years I have been walking the same route, so I knew the whole route. I knew where the road was shallow, or a footpath broken, or dangerous to walk, etc, etc. So with that in mind, I was very clear about my route. Though street lights were there, still it was dark, and was difficult to see due to the heavy rain.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">I had covered my head, so I was safe from the rain, but my feet got very wet, as there was water everywhere. At most of the places, the ankle-high water was sufficient to fill in my shoes. I continued walking. My trousers got wet easily because my jacket was not covering them.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">I kept moving on. Luckily there was not much traffic, and I was moving ahead under the rain, singing “Raindrops keep falling on my head”.  Then all of a sudden the telephone rang. I had already covered my phone with plastic. I did not open it, because I knew that it would be my worrying wife. The best option was not to open it and that was what I decided.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">Usually, it takes me about 25 minutes to reach home, but the weather was forcing me not to walk fast. Yet I sped up, to reach home at the earliest possible time.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">Then came the flooded part of a crossing, which I did know about in advance, and was ready to deal with accordingly. For me, the best way to <img data-attachment-id="632987" data-permalink="https://cyprusscene.com/2018/12/21/when-it-rains-what-are-the-effects/car-in-flood-water/" data-orig-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?fit=300%2C195&amp;ssl=1" data-orig-size="300,195" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="car in flood water" data-image-description data-medium-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?fit=300%2C195&amp;ssl=1" data-large-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?fit=300%2C195&amp;ssl=1" class="alignleft size-medium wp-image-632987 jetpack-lazy-image" src="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?resize=300%2C195&#038;ssl=1" alt width="300" height="195" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?w=300&amp;ssl=1 300w, https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?resize=150%2C98&amp;ssl=1 150w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?resize=300%2C195&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="632987" data-permalink="https://cyprusscene.com/2018/12/21/when-it-rains-what-are-the-effects/car-in-flood-water/" data-orig-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?fit=300%2C195&amp;ssl=1" data-orig-size="300,195" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="car in flood water" data-image-description="" data-medium-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?fit=300%2C195&amp;ssl=1" data-large-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?fit=300%2C195&amp;ssl=1" class="alignleft size-medium wp-image-632987" src="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?resize=300%2C195&#038;ssl=1" alt="" width="300" height="195" srcset="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?w=300&amp;ssl=1 300w, https://i2.wp.com/cyprusscene.com/wp-content/uploads/2018/12/car-in-flood-water.jpg?resize=150%2C98&amp;ssl=1 150w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript>cross a flooded place is not to think at all, and simply keep on moving ahead. That was exactly what I did that night. A bit difficult, yet I succeeded to cross the flooded part of the road.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">As I reached near to my house, I took the head cover off. That was the time when I really found out, how it feels when the raindrops fall and keep on falling  on my head. I enjoyed that feeling. My house was then not too far.  I took off my jacket, in order to enjoy the rain. For me enjoying the rain is to get wet.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">In a few minute&#8217;s time, I entered the house only to find my wife waiting for me in real anger. She said the same words that my mother used to say, whenever I enjoyed the rain as a child.  “I am telling you clearly, if you get sick no one will take care of you”, she said.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">I shrugged, smiled back to her, and went inside to change. In a short period of time, I was enjoying a cup of hot tea. I was well, and nothing had happened to me.</span></p>
<p style="text-align: justify"><span style="font-family: arial, helvetica, sans-serif">I wanted to re-live my childhood and that’s what I did. That made me happy.</span></p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='700' height='394' src='https://www.youtube.com/embed/OT1HCQcSHW0?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" data-text="Raindrops Keep Falling On My Head" data-via="Kyreniacomment" >Tweet</a></li><li class="share-facebook"><div class="fb-share-button" data-href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" data-layout="button_count"></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcyprusscene.com%2F2019%2F12%2F19%2Fraindrops-keep-falling-on-my-head%2F&#038;media=https%3A%2F%2Fi0.wp.com%2Fcyprusscene.com%2Fwp-content%2Fuploads%2F2018%2F12%2FRaining-image-2.jpg%3Ffit%3D350%252C250%26ssl%3D1&#038;description=Raindrops%20Keep%20Falling%20On%20My%20Head" data-pin-do="buttonPin" data-pin-config="beside"><img src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=700" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=700&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=700" data-recalc-dims="1" /></noscript></a></div></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button" href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-tumblr"><a class="tumblr-share-button" target="_blank" href="https://www.tumblr.com/share" data-title="Raindrops Keep Falling On My Head" data-content="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" title="Share on Tumblr">Share on Tumblr</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="https://cyprusscene.com/2019/12/19/raindrops-keep-falling-on-my-head/" data-counter="right"></script></div></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-38854786-654134-5dfbafb3d317b' data-src='https://widgets.wp.com/likes/#blog_id=38854786&amp;post_id=654134&amp;origin=cyprusscene.com&amp;obj_id=38854786-654134-5dfbafb3d317b' data-name='like-post-frame-38854786-654134-5dfbafb3d317b'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>	<div class="taxonomies">
		<p class="tax-categories taxonomy">
Categories: <a href="https://cyprusscene.com/category/reviews/" rel="category tag">Reviews</a>		</p>
<p class="tax-tags taxonomy">Tagged as: <a href="https://cyprusscene.com/tag/childhood-memories/" rel="tag">Childhood Memories</a>, <a href="https://cyprusscene.com/tag/rain-drops-keep-falling-on-my-head/" rel="tag">Rain Drops Keep Falling On My Head</a>, <a href="https://cyprusscene.com/tag/raining/" rel="tag">Raining</a></p>	</div>
	</section>
</article>
<nav class="postnav">
	<h1 class="screen-reader">Post navigation</h1>
	<div class="prev">
		<span class="more-link"><a href="https://cyprusscene.com/2019/12/19/local-football-fixtures-for-weekend-21-22-december/" rel="prev">Local Football Fixtures for weekend 21/22 December</a></span>
	</div>
	<div class="next">
		<span class="more-link"><a href="https://cyprusscene.com/2019/12/19/speaker-of-trnc-assembly-ulucay-attended-general-council-meeting/" rel="next">Speaker of TRNC Assembly Uluçay attended General Council meeting</a></span>
	</div>
</nav>
<section class="content-comments">

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/12/19/raindrops-keep-falling-on-my-head/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=38854786&#038;postid=654134&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=wavatar&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_GB&#038;jetpack_version=8.0&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=7ec12474fadae5e7f4130eafa5bf0a5400017a91#parent=https%3A%2F%2Fcyprusscene.com%2F2019%2F12%2F19%2Fraindrops-keep-falling-on-my-head%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></section>
	</div>
	</div>
<div class="col-sidebar sidebar-main" role="complementary">
<section id="google_translate_widget-4" class="widget widget_google_translate_widget"><div class="widget-wrap"><h3 class="widgettitle">Translate with Google</h3><div id="google_translate_element"></div></div></section><section id="media_image-61" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle">Cyprusscene receives a presentation from the Ministry of Tourism and Environment for promoting tourism</h3><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://cyprusscene.com/2017/11/16/trnc-ministry-of-tourism-presentation-to-cyprusscene-com/"><img width="300" height="214" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?fit=300%2C214&amp;ssl=1" class="image wp-image-608633  attachment-medium size-medium jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="608633" data-permalink="https://cyprusscene.com/2017/11/16/trnc-ministry-of-tourism-presentation-to-cyprusscene-com/margaret-sheard-ismet-esenyel-chris-elliott-image/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?fit=350%2C250&amp;ssl=1" data-orig-size="350,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Margaret Sheard, Ismet Esenyel, Chris Elliott image" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?fit=350%2C250&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?w=350&amp;ssl=1 350w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?resize=150%2C107&amp;ssl=1 150w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?resize=300%2C214&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2017/11/Margaret-Sheard-Ismet-Esenyel-Chris-Elliott-image.jpg?fit=300%2C214&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section><section id="media_image-53" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle">Write to Cyprusscene</h3><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 360px" class="wp-caption alignnone"><a href="http://cyprusscene.com/write-to-cyprusscene/"><img width="350" height="198" src="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?fit=350%2C198&amp;ssl=1" class="image wp-image-86610 aligncenter attachment-full size-full jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="86610" data-permalink="https://cyprusscene.com/2015/04/20/police-inspector-xavier-bards-two-minute-mystery-number-18/computer/" data-orig-file="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?fit=350%2C198&amp;ssl=1" data-orig-size="350,198" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Computer" data-image-description="" data-medium-file="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?fit=300%2C170&amp;ssl=1" data-large-file="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?fit=350%2C198&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?w=350&amp;ssl=1 350w, https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?resize=150%2C85&amp;ssl=1 150w, https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?resize=300%2C170&amp;ssl=1 300w" data-lazy-sizes="(max-width: 350px) 100vw, 350px" data-lazy-src="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2015/04/computer.jpg?fit=350%2C198&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><p class="wp-caption-text">And share your news with our readers</p></div></div></section><section id="em_calendar-4" class="widget widget_em_calendar"><div class="widget-wrap"><h3 class="widgettitle">Cyprus Scene Events Calendar</h3><div id="em-calendar-167" class="em-calendar-wrapper"><table class="em-calendar">
	<thead>
		<tr>
			<td><a class="em-calnav em-calnav-prev" href="/2019/12/19/raindrops-keep-falling-on-my-head/?ajaxCalendar=1&#038;mo=11&#038;yr=2019" rel="nofollow">&lt;&lt;</a></td>
			<td class="month_name" colspan="5">Dec 2019</td>
			<td><a class="em-calnav em-calnav-next" href="/2019/12/19/raindrops-keep-falling-on-my-head/?ajaxCalendar=1&#038;mo=1&#038;yr=2020" rel="nofollow">&gt;&gt;</a></td>
		</tr>
	</thead>
	<tbody>
		<tr class="days-names">
			<td>M</td><td>T</td><td>W</td><td>T</td><td>F</td><td>S</td><td>S</td>
		</tr>
		<tr>
							<td class="eventless-pre">
										25									</td>
								<td class="eventless-pre">
										26									</td>
								<td class="eventless-pre">
										27									</td>
								<td class="eventless-pre">
										28									</td>
								<td class="eventful-pre">
										<a href="https://cyprusscene.com/events-2/2019-11-29/" title="KADS &#8211; Sleigh Bells in the Park, Steph is at the Aruba Bar">29</a>
									</td>
								<td class="eventful-pre">
										<a href="https://cyprusscene.com/events/st-andrews-church-kyrenia-christmas-stall/" title="St Andrew&#8217;s Church, Kyrenia &#8211; Christmas Stall">30</a>
									</td>
								<td class="eventless">
										1									</td>
				</tr><tr>				<td class="eventful">
										<a href="https://cyprusscene.com/events/kads-sleigh-bells-in-the-park-2/" title="KADS &#8211; Sleigh Bells in the Park">2</a>
									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/kads-sleigh-bells-in-the-park-3/" title="KADS &#8211; Sleigh Bells in the Park">3</a>
									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/kads-sleigh-bells-in-the-park-4/" title="KADS &#8211; Sleigh Bells in the Park">4</a>
									</td>
								<td class="eventless">
										5									</td>
								<td class="eventless">
										6									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events-2/2019-12-07/" title="Christmas Sing-A-Long and Party at Bar 33 &#8211; The Old Mill, KAR Christmas Bazaar 2019, St Andrew&#8217;s Church, Kyrenia &#8211; Christmas Stall">7</a>
									</td>
								<td class="eventless">
										8									</td>
				</tr><tr>				<td class="eventful">
										<a href="https://cyprusscene.com/events/susies-christmas-music-quiz-at-charlies-sports-bar/" title="Susies Christmas Music Quiz at Charlies Sports Bar">9</a>
									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events-2/2019-12-10/" title="Andy Reay is at Seawise Restaurant and Bar, Quiz Night in aid of Tulips at the Cabin Restaurant and Bar">10</a>
									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/step-into-christmas-with-johnny-lee-at-the-alvadar-bar/" title="Step into Christmas with Johnny Lee at the Alvadar Bar">11</a>
									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/aruba-bar-presents-blue-tears/" title="Aruba Bar presents Blue Tears">12</a>
									</td>
								<td class="eventless">
										13									</td>
								<td class="eventless">
										14									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/christmas-songs-with-gavin-at-the-aruba-bar/" title="Christmas songs with Gavin at the Aruba Bar">15</a>
									</td>
				</tr><tr>				<td class="eventless">
										16									</td>
								<td class="eventless">
										17									</td>
								<td class="eventless">
										18									</td>
								<td class="eventful-today">
										<a href="https://cyprusscene.com/events-2/2019-12-19/" title="Christmas Song Bingo at Just Nice, Paw @ Day Brick-a-Brack stall at the Food Lodge, The Christmas Quiz with Susie at the Balti House">19</a>
									</td>
								<td class="eventless">
										20									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/christmas-at-the-potting-shed/" title="Christmas at the Potting Shed">21</a>
									</td>
								<td class="eventless">
										22									</td>
				</tr><tr>				<td class="eventless">
										23									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/dynasty-christmas-eve-party-with-andy-reay/" title="Dynasty Christmas Eve Party with Andy Reay">24</a>
									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/christmas-day-dinner-at-al-shaheen/" title="Christmas Day Dinner at Al Shaheen">25</a>
									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events/red-lion-pub-boxing-day-alternative-races/" title="Red Lion Pub &#8211; Boxing Day Alternative Races">26</a>
									</td>
								<td class="eventless">
										27									</td>
								<td class="eventless">
										28									</td>
								<td class="eventless">
										29									</td>
				</tr><tr>				<td class="eventless">
										30									</td>
								<td class="eventful">
										<a href="https://cyprusscene.com/events-2/2019-12-31/" title="New Year with GP King at Dynasty, New Years Eve Dinner at  Al Shaheen, New Years Eve Dinner at Rafters Restaurant">31</a>
									</td>
								<td class="eventless-post">
										1									</td>
								<td class="eventless-post">
										2									</td>
								<td class="eventless-post">
										3									</td>
								<td class="eventless-post">
										4									</td>
								<td class="eventless-post">
										5									</td>
						</tr>
	</tbody>
</table></div></div></section><section id="media_image-20" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle">TRNC 14 Day Weather Forecast &#8211; Click Picture</h3><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="http://www.forecast.co.uk/kyrenia.html"><img width="143" height="107" src="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2012/10/weather.jpg?fit=143%2C107&amp;ssl=1" class="image wp-image-6959 aligncenter attachment-160x107 size-160x107 jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="6959" data-permalink="https://cyprusscene.com/weather/" data-orig-file="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2012/10/weather.jpg?fit=185%2C138&amp;ssl=1" data-orig-size="185,138" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Weather" data-image-description="" data-medium-file="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2012/10/weather.jpg?fit=185%2C138&amp;ssl=1" data-large-file="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2012/10/weather.jpg?fit=185%2C138&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2012/10/weather.jpg?w=185&amp;ssl=1 185w, https://i1.wp.com/cyprusscene.com/wp-content/uploads/2012/10/weather.jpg?resize=150%2C112&amp;ssl=1 150w" data-lazy-sizes="(max-width: 143px) 100vw, 143px" data-lazy-src="https://i1.wp.com/cyprusscene.com/wp-content/uploads/2012/10/weather.jpg?fit=143%2C107&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section><section id="media_image-59" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle">Currency Converter</h3><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="http://www.xe.com/currencyconverter/convert/?Amount=1&#038;From=GBP&#038;To=TRY"><img class="image aligncenter" src="https://cyprusscene.com/wp-content/uploads/2017/09/uk-money-2.jpg" alt="" width="200" height="132" /></a></div></section><section id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="widget-wrap"><div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
	<a href="https://automattic.com/cookies/" >
		Cookie Policy	</a>
</div>
</div></section><section id="text-18" class="widget widget_text"><div class="widget-wrap"><h3 class="widgettitle">TRNC Ministry websites click below</h3>			<div class="textwidget"></div>
		</div></section><section id="sow-image-grid-2" class="widget widget_sow-image-grid"><div class="widget-wrap"><div class="so-widget-sow-image-grid so-widget-sow-image-grid-default-c51e448a0a62">	<div class="sow-image-grid-wrapper"
		data-max-width="100"		data-max-height="100">
					<div class="sow-image-grid-image">
									<a href="https://kktcb.org/en"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2019/04/TRNC-logo-3a-1-e1555237446976.jpg" alt="" title="TRNC Presidency">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://kktcbasbakanlik.org/"
					>
								<img src="https://cyprusscene.com/wp-content/uploads/2015/02/trnc-gov-image-4.png" alt="" title="TRNC Prime Ministry">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://mfa.gov.ct.tr/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2018/03/TRNC-min-Public-works-transport.jpg" alt="" title="TRNC Ministry of Foreign Affairs and Deputy Prime Ministry">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://turizm.gov.ct.tr/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2018/03/TRNC-min-Public-works-transport.jpg" alt="" title="TRNC Ministry of Tourism and Enviroment">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="https://icisleri.gov.ct.tr/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2018/03/TRNC-min-Public-works-transport.jpg" alt="" title="TRNC Ministry of Interior">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="https://csgb.gov.ct.tr/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2018/03/TRNC-min-Public-works-transport.jpg" alt="" title="TRNC Ministry of Labour and Social Security">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://bub.gov.ct.tr/en-us/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2018/03/TRNC-min-Public-works-transport.jpg" alt="" title="TRNC Ministry of Public Works and Transportation">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://welcometonorthcyprus.co.uk/"
					>
								<img src="http://welcometonorthcyprus.co.uk/" alt="" title="North Cyprus Tourism Centre">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://pio.mfa.gov.ct.tr/en/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2019/04/TRNC-PIO.jpg" alt="" title="TRNC Public Information Office">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://www.maliye.gov.ct.tr/maliye/f?p=100:1"
					>
								<img src="https://cyprusscene.com/wp-content/uploads/2019/04/TRNC-Ministry-of-Finance-2.jpg" alt="" title="TRNC Ministry of Financ 2">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://saglik.gov.ct.tr/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2018/03/TRNC-min-Public-works-transport.jpg" alt="" title="TRNC Ministry of Health">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://posta.gov.ct.tr/en-us/%C3%BCstmenu/anasayfa.aspx"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2018/02/TRNC-Post-Office-Logao-e1555245348879.jpg" alt="" title="TRNC Postal service">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://www.polis.gov.ct.tr/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2017/04/trnc-police-logo-e1555245491246.jpg" alt="" title="TRNC Police">									</a>
							</div>
			</div>
</div></div></section><section id="media_video-2" class="widget widget_media_video"><div class="widget-wrap"><h3 class="widgettitle">CyprusScene.com Reviews are coming and more</h3><style>.widget.widget_media_video iframe { margin: 0; }</style><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-654134-1" loop="1" preload="metadata" controls="controls"><source type="video/mp4" src="https://cyprusscene.com/wp-content/uploads/2018/12/2018-Facebook-memory-of-CyprusScene.mp4?_=1" /><source type="video/mp4" src="https://cyprusscene.com/wp-content/uploads/2018/12/2018-Facebook-memory-of-CyprusScene.mp4?_=1" /><a href="https://cyprusscene.com/wp-content/uploads/2018/12/2018-Facebook-memory-of-CyprusScene.mp4">https://cyprusscene.com/wp-content/uploads/2018/12/2018-Facebook-memory-of-CyprusScene.mp4</a></video></div></div></section></div>
</div>

<footer role="contentinfo" id="footer" class="container">
	<aside class="footer-widgets sidebar-footer">
		<section id="sow-image-grid-4" class="widget widget_sow-image-grid"><div class="widget-wrap"><div class="so-widget-sow-image-grid so-widget-sow-image-grid-default-c51e448a0a62">	<div class="sow-image-grid-wrapper"
		data-max-width="100"		data-max-height="100">
					<div class="sow-image-grid-image">
									<a href="http://www.brtk.net/radio-template/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2019/04/BRT-54-yil-image-2.jpg" alt="" title="Bayak Radio and Television">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="https://cyprusscene.com/2019/01/24/finding-turkish-cypriot-friends-in-australia/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2019/04/ZZZ-finding-Turkish-Cypriots-in-Australia-sml.jpg" alt="" title="Find Turkish Cypriot friends on Australian Radio">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://tkodkk.org/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img src="https://cyprusscene.com/wp-content/uploads/2019/04/TKOD-sml.jpg" alt="" title="TKOD Road Traffic Accident Prevention Association">									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="http://www.meritta.org/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img width="150" height="114" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Meritta.jpg?fit=150%2C114&amp;ssl=1" class="attachment-thumbnail size-thumbnail jetpack-lazy-image" alt="" title="Meritta Turtle Rehabilitation centre" data-attachment-id="643865" data-permalink="https://cyprusscene.com/meritta/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Meritta.jpg?fit=210%2C159&amp;ssl=1" data-orig-size="210,159" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Meritta" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Meritta.jpg?fit=210%2C159&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Meritta.jpg?fit=210%2C159&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Meritta.jpg?w=210&amp;ssl=1 210w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Meritta.jpg?resize=150%2C114&amp;ssl=1 150w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Meritta.jpg?fit=150%2C114&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="https://www.facebook.com/AcleanCyprus/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img width="150" height="150" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?fit=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail jetpack-lazy-image" alt="" title="Temiz Kibris/A Clean Cyprus" data-attachment-id="643866" data-permalink="https://cyprusscene.com/temiz-kibris-a-clena-cyprus/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?fit=200%2C200&amp;ssl=1" data-orig-size="200,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Temiz Kibris A clena Cyprus" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?fit=200%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?fit=200%2C200&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?w=200&amp;ssl=1 200w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?resize=120%2C120&amp;ssl=1 120w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Temiz-Kibris-A-clena-Cyprus.jpg?fit=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="https://www.kartrnc.org/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img width="150" height="150" src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?fit=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail jetpack-lazy-image" alt="" title="Kyrenia Animal Rescue" data-attachment-id="616281" data-permalink="https://cyprusscene.com/2018/03/19/alsancak-belediyesi-and-kar-unite-on-new-project/kar-logo-2017/" data-orig-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?fit=160%2C160&amp;ssl=1" data-orig-size="160,160" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="KAR logo 2017" data-image-description="" data-medium-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?fit=160%2C160&amp;ssl=1" data-large-file="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?fit=160%2C160&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?w=160&amp;ssl=1 160w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?resize=120%2C120&amp;ssl=1 120w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?resize=70%2C70&amp;ssl=1 70w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/cyprusscene.com/wp-content/uploads/2018/03/KAR-logo-2017.jpg?fit=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
							</div>
			</div>
</div></div></section><section id="sow-image-grid-5" class="widget widget_sow-image-grid"><div class="widget-wrap"><div class="so-widget-sow-image-grid so-widget-sow-image-grid-default-c51e448a0a62">	<div class="sow-image-grid-wrapper"
		data-max-width="100"		data-max-height="100">
					<div class="sow-image-grid-image">
									<a href="http://www.hope4petsnorthcyprus.com"
					>
								<img width="100" height="100" src="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Hope-4-Pets-e1566894828626.jpg?fit=100%2C100&amp;ssl=1" class="attachment-full size-full jetpack-lazy-image" alt="" title="Hope 4 Pets North Cyprus" data-attachment-id="643982" data-permalink="https://cyprusscene.com/hope-4-pets-3/" data-orig-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Hope-4-Pets-e1566894828626.jpg?fit=100%2C100&amp;ssl=1" data-orig-size="100,100" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Hope 4 Pets" data-image-description="" data-medium-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Hope-4-Pets-e1566894828626.jpg?fit=100%2C100&amp;ssl=1" data-large-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Hope-4-Pets-e1566894828626.jpg?fit=100%2C100&amp;ssl=1" data-lazy-src="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/06/Hope-4-Pets-e1566894828626.jpg?fit=100%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
							</div>
					<div class="sow-image-grid-image">
									<a href="https://www.facebook.com/taskentdogaparki/"
																		target="_blank" 																								rel="noopener noreferrer" 											>
								<img width="100" height="100" src="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/08/Taskent-image.jpg?fit=100%2C100&amp;ssl=1" class="attachment-full size-full jetpack-lazy-image" alt="" title="Taskent Nature Park" data-attachment-id="647648" data-permalink="https://cyprusscene.com/taskent-image/" data-orig-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/08/Taskent-image.jpg?fit=100%2C100&amp;ssl=1" data-orig-size="100,100" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Taskent image" data-image-description="" data-medium-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/08/Taskent-image.jpg?fit=100%2C100&amp;ssl=1" data-large-file="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/08/Taskent-image.jpg?fit=100%2C100&amp;ssl=1" data-lazy-src="https://i2.wp.com/cyprusscene.com/wp-content/uploads/2019/08/Taskent-image.jpg?fit=100%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
							</div>
			</div>
</div></div></section>	</aside>
	<section class="footer-wrap">
		<ul class="footer-site-content-links">
			<li class="footer-top-categories"><strong>Top categories: </strong> <a href="https://cyprusscene.com/category/news/">News</a> <a href="https://cyprusscene.com/tag/mustafa-akinci/">Mustafa Akıncı</a></li><li class="footer-social-links"><strong>Social links: </strong> <div class="social_links menu-social-links"><a href="http://twitter.com/Kyreniacomment" class="social_link_twitter"><span>Twitter<span></a><a href="https://www.facebook.com/cyprusscene/" class="social_link_facebook"><span>Facebook<span></a><a href="https://plus.google.com/108259488521191588705" class="social_link_google_plus"><span>Google+<span></a><a href="http://kyreniacommentator.tumblr.com/" class="social_link_tumblr"><span>Tumblr<span></a><a href="http://www.linkedin.com/profile/view?id=AAoAAA0822gBMwFURhop2dO9v3lv81Wyg4GQNTw" class="social_link_linkedin"><span>LinkedIn<span></a></div></li>		</ul>
		<div class="footer-credits">
			<a href="https://wordpress.com/?ref=footer_custom_svg" title="Create a website or blog at WordPress.com"><svg style="fill: currentColor; position: relative; top: 1px;" width="14px" height="15px" viewBox="0 0 14 15" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" aria-labelledby="title" role="img">
				<title id="title">Create a website or blog at WordPress.com</title>
				<path d="M12.5225848,4.97949746 C13.0138466,5.87586309 13.2934037,6.90452431 13.2934037,7.99874074 C13.2934037,10.3205803 12.0351007,12.3476807 10.1640538,13.4385638 L12.0862862,7.88081544 C12.4453251,6.98296834 12.5648813,6.26504621 12.5648813,5.62667922 C12.5648813,5.39497674 12.549622,5.17994084 12.5225848,4.97949746 L12.5225848,4.97949746 Z M7.86730089,5.04801561 C8.24619178,5.02808979 8.58760099,4.98823815 8.58760099,4.98823815 C8.9267139,4.94809022 8.88671369,4.44972248 8.54745263,4.46957423 C8.54745263,4.46957423 7.52803983,4.54957381 6.86996227,4.54957381 C6.25158863,4.54957381 5.21247202,4.46957423 5.21247202,4.46957423 C4.87306282,4.44972248 4.83328483,4.96816418 5.17254589,4.98823815 C5.17254589,4.98823815 5.49358462,5.02808979 5.83269753,5.04801561 L6.81314716,7.73459399 L5.43565839,11.8651647 L3.14394256,5.04801561 C3.52312975,5.02808979 3.86416859,4.98823815 3.86416859,4.98823815 C4.20305928,4.94809022 4.16305906,4.44972248 3.82394616,4.46957423 C3.82394616,4.46957423 2.80475558,4.54957381 2.14660395,4.54957381 C2.02852925,4.54957381 1.88934333,4.54668493 1.74156477,4.54194422 C2.86690406,2.83350881 4.80113651,1.70529256 6.99996296,1.70529256 C8.638342,1.70529256 10.1302017,2.33173369 11.2498373,3.35765419 C11.222726,3.35602457 11.1962815,3.35261718 11.1683554,3.35261718 C10.5501299,3.35261718 10.1114609,3.89113285 10.1114609,4.46957423 C10.1114609,4.98823815 10.4107217,5.42705065 10.7296864,5.94564049 C10.969021,6.36482346 11.248578,6.90326506 11.248578,7.68133501 C11.248578,8.21992476 11.0413918,8.84503256 10.7696866,9.71584277 L10.1417574,11.8132391 L7.86730089,5.04801561 Z M6.99996296,14.2927074 C6.38218192,14.2927074 5.78595654,14.2021153 5.22195356,14.0362644 L7.11048207,8.54925635 L9.04486267,13.8491542 C9.05760348,13.8802652 9.07323319,13.9089317 9.08989995,13.9358945 C8.43574834,14.1661896 7.73285573,14.2927074 6.99996296,14.2927074 L6.99996296,14.2927074 Z M0.706448182,7.99874074 C0.706448182,7.08630113 0.902152921,6.22015756 1.25141403,5.43749503 L4.25357806,13.6627848 C2.15393732,12.6427902 0.706448182,10.4898387 0.706448182,7.99874074 L0.706448182,7.99874074 Z M6.99996296,0.999 C3.14016476,0.999 0,4.13905746 0,7.99874074 C0,11.8585722 3.14016476,14.999 6.99996296,14.999 C10.8596871,14.999 14,11.8585722 14,7.99874074 C14,4.13905746 10.8596871,0.999 6.99996296,0.999 L6.99996296,0.999 Z" id="wordpress-logo-simplified-cmyk" stroke="none" fill=“currentColor” fill-rule="evenodd"></path>
			</svg></a>
			<span class="sep" role="separator" aria-hidden="true"> | </span>
		</div>
	</section>
</footer>

<!--  -->
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-124258329-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/cyprusscene.com\/2019\/12\/19\/raindrops-keep-falling-on-my-head\/":654134};
	</script>
							<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_GB/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<script id="tumblr-js" type="text/javascript" src="https://assets.tumblr.com/share-button.js"></script>	<div id="sharing_email" style="display: none;">
		<form action="/2019/12/19/raindrops-keep-falling-on-my-head/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://cyprusscene.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script><link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201951'></script>
<script type='text/javascript' src='https://cyprusscene.com/wp-content/plugins/so-widgets-bundle/js/lib/imagesloaded.pkgd.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://cyprusscene.com/wp-content/plugins/so-widgets-bundle/widgets/image-grid/js/image-grid.min.js?ver=1.15.9'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Decaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/masonry.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_GB"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cyprusscene.com/wp-content/plugins/newsletter/subscription/validate.js?ver=6.4.1'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/modules/theme-tools/responsive-videos/responsive-videos.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/cyprusscene.com\/wp-admin\/admin-ajax.php","nonce":"d17e9c7afb","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/cyprusscene.com\/wp-login.php?redirect_to=https%3A%2F%2Fcyprusscene.com%2F2019%2F12%2F19%2Fraindrops-keep-falling-on-my-head%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script async="async" type='text/javascript' src='https://cyprusscene.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wp_google_translate_widget = {"lang":"en_GB","layout":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/widgets/google-translate/google-translate.min.js'></script>
<script type='text/javascript' src='//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit&#038;ver=5.3.2'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/mediaelement-and-player.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/mediaelement-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/wp-mediaelement.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/renderers/vimeo.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=201951#ver=201951&amp;lang=en-gb' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=38854786&postid=654134&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=wavatar&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_GB&jetpack_version=8.0&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=7ec12474fadae5e7f4130eafa5bf0a5400017a91#parent=https%3A%2F%2Fcyprusscene.com%2F2019%2F12%2F19%2Fraindrops-keep-falling-on-my-head%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=38854786&postid=654134&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=wavatar&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_GB&jetpack_version=8.0&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=7ec12474fadae5e7f4130eafa5bf0a5400017a91#parent=https%3A%2F%2Fcyprusscene.com%2F2019%2F12%2F19%2Fraindrops-keep-falling-on-my-head%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201951.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'38854786',post:'654134',tz:'2',srv:'cyprusscene.com'} ]);
	_stq.push([ 'clickTrackerInit', '38854786', '654134' ]);
</script>

</body>
</html>
